Joomla, errore: Database Error: Unable to connect to the database:Could not connect to MySQL
Joomla utilizza un database. Se per qualche motivo non riesce a collegarsi al database, può ricevere questo messaggio:
Database Error: Unable to connect to the database:Could not connect to MySQL
Nel file configuration.php (che si trova nella cartella in cui è installato Joomla) trova queste impostazioni per la connessione al database:
var $host = 'localhost'; // È sempre localhost
var $user = 'XXX_ZZZ'; // Al posto di XXX c'è il nome utente del pannello di controllo, al posto di ZZZ l'utente del database
var $db = 'XXX_YYY'; // Al posto di XXX c'è il nome utente del pannello di controllo, al posto di YYY il nome del database
var $password = 'password'; // La password che ha assegnato all'utente del database
Se non riesce a collegarsi, probabilmente c'è qualcosa che non va nei dati indicati sopra.
Acceda al pannello di controllo e scelga il menu MySQL. Scelga quindi il database di Joomla (facendo clic su di esso): vengono mostrati gli utenti del database presenti. Se necessario crei un nuovo utente del database e inserisca nome utente e password in configuration.php. Se l'utente del database esiste già, per sicurezza ne modifichi la password, in modo che corrisponda a quella in configuration.php.
Se ha installato Joomla tramite Installatron, può trovare il nome del database anche tramite Installatron.
